Cannot resolve netlib dependency when building from Maven with XGBoost

Description

Building on Maven with h2o-ext-xgboost on a version later than 3.18.0.11 as a dependency fails with the following error message:

I can replicate this on both my local machine (OSX) and on a fresh EC2 instance with the Amazon Linux AMI and the latest version of Maven with the following pom.xml:

I can build in SBT with no issues. This appears to be related to a change between 3.18.0.11 and 3.20.0.1, as I can build fine against 3.18.0.11.

Assignee

Jordan Bentley

Fix versions

Reporter

Jordan Bentley

Support ticket URL

None

Labels

Affected Spark version

None

Customer Request Type

None

Task progress

None

CustomerVisible

Yes

Components

Priority

Major
Configure