Add new limitation in XGBoost chapter

Description

Update to Limitations in XGBoost chapter in the docs.

The supported platform table needs to be updated. Replace "Ubuntu 14.04, g++ 4.7" with "Ubuntu 18.04, g++ 5"

From email thread:

Hi,
We are planning to upgrade XGBoost to 0.90 in next major. Since 0.90 XGBoost requires gcc version 5 or later. Since Centos6 only has support for gcc 4 we will be dropping support for XGBoost on older version of linux (Centos6 and Ubuntu14).

Let me know if you see any issues with this please.

Jan Sterba

Environment

None

Status

Assignee

zain.haq

Fix versions

Reporter

Angela Bartz

Support ticket URL

None

Labels

None

Release Priority

None

Affected Spark version

None

Customer Request Type

None

Task progress

None

CustomerVisible

No

Priority

Major